Creating Web Pages with Netscape Composer

Netscape Composer lets you create your own web pages and publish them on the web. You don't have to know HTML to use Composer; it is as easy to use as a word processor.

Toolbar buttons let you add lists, tables, images, links to other pages, colors, and font styles. You can see what your document will look like on the Web as you create it, and you can easily share your document with other users, no matter what type of browser or HTML-capable email program they use.

To start using Netscape Composer:

· Click the Composer icon in the lower-left corner of any Netscape window. 

Creating a New Page

Netscape Composer is an HTML (Hypertext Markup Language) editor that allows you to create and edit web pages. Composer is a WYSIWYG (What You See Is What You Get) editor, so you can display how your page will look to the reader as you're creating it. It is not necessary for you to know HTML, since most of the basic HTML functions are available as commands from the toolbars and menus.

Composer also lets you edit the HTML source if you want. To view or edit the HTML source code, open the View menu, and choose HTML Source, or click the <HTML> Source tab in the Edit Mode toolbar at the bottom of the Composer window.

To create a web page, use one of the methods described below. Once you've started a page, you can add and edit text just as you would in a word processor.

To create a new page from the Navigator browser:

· Open the File menu, choose New, and then Composer Page. A Composer window containing a blank page opens.

To edit a page you're currently browsing in Navigator:

· In the Navigator window of the page you're viewing, open the File menu and choose Edit Page. You see a Composer window that contains the page you're viewing.

To create a new page in Composer:

· Click the New button in Composer's toolbar.

To start from an HTML file stored on your local drive:

1. Open the Window menu and choose Composer. You see the Composer window.

2. Open the File menu and choose Open File. You see the Open HTML File dialog box.

3. On your local drive, locate the file that you want to edit.

4. Click Open to display the specified file in a Composer window.

To edit a web page:

1. Open the Window menu and choose Navigator.

2. Go to a web page by typing the URL of the page (for example, http://home.netscape.com) in the Location Bar and pressing Enter (Return on Macintosh OS).

3. Open the File menu and choose Edit Page.

Tip: In the Composer window you can quickly open the most recent file you've been working on by opening the File menu, choosing Recent Pages, and then selecting the file you want from the list. 

Saving and Browsing Your New Page

You can save Composer documents in HTML or text-only format. Saving a document in HTML format preserves the document's formatting, such as text styles (for example, bold or italic), tables, links, and images. Saving a document in text-only format removes all the HTML tags but preserves the document's text.

To save a document as an HTML file:

· Open the File menu and choose Save or click the Save button on the Composition toolbar. 

If you haven't already given your page a title, Composer prompts you to do so. Composer displays the page title in the browser window's title bar when you view the page in the browser. The document's page title also appears in your list of bookmarks if you bookmark the page.

Composer then prompts you to enter a filename and specify the location where you want to save the file. Make sure you preserve the .html extension in the filename.

To change the filename or location of an existing HTML file:

· Choose Save As and select a different filename or location.

When you save a page in Composer, all parts of the page (the HTML, images and other files, such as sound files and style sheets), are saved locally on your hard drive. If you only want to save the HTML part of the page, you must change the Composer preference for saving pages. See Composer Preferences - Composer for more information on changing Composer's setting for saving pages.

If an image location is absolute (starts with "http://") and you are connected to the Internet, you will still see that image in the document in Composer and Navigator. However, if the image location is relative to the page location (starts with "file:///"), then you won't see the image in the local version of the document.

To save a document as a text-only file:

1. Open the File menu and choose Export to Text.

2. Enter the filename and specify the location where you want to save the file.

Note: Images do not appear in documents saved in the text-only format.

Tip: You can choose Revert to Last Saved from the File menu to retrieve the most recently saved copy of the document in which you're working. Keep in mind that your current changes will be lost.

To view your page in a browser window in order to test your links:

· Open the File menu and choose Browse Page (or click Browse in the Composition toolbar). If you have not yet saved your document, Composer prompts you to enter a page title, filename, and location. The Composer window remains open behind the new Navigator window.

Changing Text Color, Style, and Font

To change the style, color, or font of selected text:

1. Select the text you want to format.

2. Open the Format menu and choose one of the following:

· Font: Use this to choose a font. If you prefer to use fonts specified by the reader's browser, select Variable Width or Fixed Width. 

Note: Not all fonts installed on your computer appear. Instead of specifying a font that may not be available to all who view your web page, it's generally best to select one of the fonts provided in the menu since these fonts work on every computer. For example, the fonts Helvetica, Arial, Times, and Courier generally look the same when viewed on different computers. If you select a different font, it may not look the same when viewed using a different computer.

· Size: Use this to choose a relative font size or select an option to increase or decrease text size (relative to the surrounding text).

· Text Style: Use this to select a style, such as italic, bold, or underline, or to apply a structured style, for example, Code.

· Text Color: Use this to choose a color from the color picker. If you are familiar with HTML hexadecimal color codes, you can type a specific code or you can just type a color name (for example, "blue"). You'll find a handy color code converter here.

To change the background color of the page:

1. Click anywhere in the page.

2. Click the background color block in the Format toolbar.

3. Choose a background color from the Block Background Color dialog box.

4. Click OK.

Tip: To quickly change the color of text to the color last used, select the text, then press Shift and click on the text color block in the Format toolbar. This is useful when you want to use one color for separate lines of text.

You can also use an image as a background. See Setting Page Colors and Backgrounds.

Inserting a Table

Tables are useful for organizing text, pictures, and data into formatted rows and columns. To insert a table:

1. Click to place the insertion point where you want the table to appear.

2. Click the Table button 
3. Type the number of rows and columns you want.

· (Optional) Enter a size for the table width, and select either percentage of the window or pixels.

4. Enter a number for the border thickness (in pixels); enter zero for no border. 

Note: Composer uses a red dotted line to indicate tables with a zero border; the dotted line disappears when the page is viewed in a browser.

5. To apply additional table attributes or JavaScript, click Advanced Edit to display the Advanced Property Editor.

6. Click OK to confirm your settings and view your new table.

To change additional properties for your new table, see Changing a Table's Properties.

Tip: To insert a table within a table, open the Insert menu and choose Table.

Inserting an Image into Your Page

You can insert GIF, JPEG, BMP, and PNG (Portable Network Graphics) images into your web page. You can also use them to create links. When you insert an image, Composer saves a reference to the image in your page.

Note: If you plan to publish your pages to the web, it's best not to use BMP images in your pages.

Tip: It's best to first save or publish your page before you insert images into it. This allows Composer to automatically use relative references to images once you insert them.

To insert an image:

1. Click to place the insertion point where you want the image to appear.

2. Click the Image button [image: image1]on the toolbar, or open the Insert menu and choose Image. You see the Image Properties dialog box.

3. Type the location and filename of the image file, or click Choose File to search for an image file on your hard drive or network.

4. Type a simple description of your image as the alternate text that will appear in text-only browsers (as well as other browsers) when an image is loading or when image loading is disabled. 

Alternatively, you can choose not to include alternate text.

5. If needed, click other tabs so you can adjust the settings (for example, alignment) in the Image Properties dialog box.

Tip: To quickly insert an image: Drag and drop it onto your page.

Tip: To insert a line break after all images in a paragraph, choose Break Below Images from the Insert menu.

Tip: To resize an image, click it once to display resize handles. Click and drag a handle to make the image smaller or larger.

Creating Links Within the Same Page

To create a link within the same page, for example a link that the reader can use to jump from one section to another, you must create an anchor (target location), and then create a link that points to the anchor. Anchors are also called named anchors.

1. Click to place the insertion point at the beginning of a line where you want to create an anchor, or select some text.

2. Open the Insert menu and choose Named Anchor. You see the Named Anchor Properties dialog box.

3. Type a unique name for the anchor in the Anchor Name field (up to 30 characters). If you include spaces, they will be converted to underscores ( _ ). If you selected some text in step 1, this box already contains a name.

4. Click OK. An anchor icon appears in your document to mark the anchor's location: [image: image2]
To create the link on which readers can click to jump to the anchor:

1. Select the text or image that you want to link to the anchor.

2. Click the Link button or open the Insert menu and choose Link. You see the Link Properties dialog box.

· If you're creating a link to an HTML file on your computer, click Choose File to locate it.

· If you're creating a link to a named anchor (target), select it from the list of the anchors currently available in the page.

· If you're creating a link to a level heading (for example, Heading 1 - Heading 6), select it from the list of headings currently available in the page.

3. Click OK.

Note: To test the link you just created, open the File menu and choose Browse Page, then click the link.

Tip: If you did not first create named anchors, you can use the Link dialog box to create links to headings that already occur in the page.

Creating Links to Other Pages

You can create links from your page to local pages on your own computer or on your workplace's network, or to remote pages on the Internet.

Tip: It's best to first save or publish your page before you create links to other pages. This allows Composer to automatically use relative references for links once you create them.

To create a link to another page:

1. Click to place the insertion point where you want to create a link, or select the text or image that you want to link to the anchor.

2. Click the Link button. You see the Link Properties dialog box.

3. Define your link:

· Link text: If you've already selected an image file or text before clicking the Link button, the selected text or file will be entered here. Otherwise, you must enter the text that you want to use as the link.

· Link Location: Type the local path and filename or remote URL of the page you want to link to. If you're not sure of the path and filename for a local file, click Choose File to look for it on your hard disk or network. For remote URLs, you can copy the URL from the browser location field. Alternatively, you can select a named anchor or a heading in the current page that you want to link to.

· URL is relative to page location: If checked, Composer converts the URL to be relative to the page's location. This is especially useful if you plan to publish your pages to a web server so that others can view them. Using relative URLs allows you to keep all your linked files in the same place relative to each other, regardless of their location on your hard disk or a web server. 

Deselecting this option causes Composer to convert the URL to a full (absolute) URL. You typically use absolute URLs when linking to pages on other web servers (not stored locally on your hard disk).

If you have unsaved changes, you must first save the page in order to enable this checkbox.

4. To apply additional attributes or JavaScript events, click Advanced Edit to display the Advanced Property Editor.

5. Click OK.

6. To test the link you just created, click the Browse button and then click the link to make sure it works as expected.

To create an email creation link, enter the following into the Link to a… entry:mailto:user@server.com

Tip: You can copy a link quickly by clicking and dragging the link from another window and then dropping it onto your page. For example, you can click and drag a link from a web page, bookmark, or Mail window and drop it onto your page. You can also right-click (Control+click on Macintosh OS) a link on a web page and choose Copy Link Location from the menu. Then you can paste the link location into the Link Location field in the Link Properties dialog box.

Publishing a Document

Tip: It's best to first save or publish your page before you insert links or images into it. This allows Composer to automatically use relative references for links and images once you insert them.

To publish a document:

1. Open the HTML document that you want to publish, or create a new Composer document.

2. When you're ready to publish the document remotely, click the Publish button.

If you have published this document before, Composer remembers the document's publishing settings and starts publishing the document. While publishing is in progress, Composer displays a publishing status dialog box.

· If you have never published this document before, Composer displays the Settings tab in the Publish Page dialog box so you can enter information about the document's remote publishing location. See Publish Page - Settings for more information. When you're done entering information, click Publish.

· If you have never saved the document, Composer displays the Publish tab in the Publish Page dialog box, so you can enter the document's filename. See Publish Page - Publish for more information. After entering the filename, click Publish.

3. To browse your published page, click the Browse button. Test the page's links and make sure there are no missing images.

4. Continue editing the page as necessary. When you're ready to update the remote page with your changes, click the Publish button.

When you publish a document for the first time, Composer changes the document's file:/// URL to an http:// URL to indicate that you are now editing the published document. If you want to save the document locally (on your computer's hard disk), click the Save button. You'll be prompted to choose a filename and location on your hard disk for the document.

